Max Git und HD51 Bau bricht ab

Antworten
Benutzeravatar
annie
NI - Team
Beiträge: 1010
Registriert: Di 5. Apr 2016, 18:46
Wohnort: zuhause
Box: 1x E4HD, 4x HD51,1x VuUno4K

Max Git und HD51 Bau bricht ab

Beitrag von annie »

.config :

Code: Alles auswählen

TARGET_ARCH=arm
BOXTYPE=armbox
BOXMODEL=hd51
FLAVOUR=neutrino-max
GCC_VERSION=8.5.0
OPTIMIZATIONS=size
EXTERNAL_LCD=lcd4linux
IMAGE_LAYOUT=single
Bildschirmfoto vom 2023-06-17 12-04-22.png
Benutzeravatar
max_10
NI - VIP
Beiträge: 162
Registriert: Di 12. Apr 2016, 13:06

Re: Max Git und HD51 Bau bricht ab

Beitrag von max_10 »

die prepare-for-bs.sh ausgeführt?
in LinuxMint 21.1 hat das immer ausgereicht (hatte ich bis vor 2 Tagen hier auch immer am laufen), bei Debian Bookworm (was ich im Moment nutze) ist mir an der stelle noch ein anderer Fehler aufgefallen, der aber auch beseitigt ist.

falls prepare-for-bs.sh nicht ausreicht, obwohl dadurch libmount-dev installiert wird, mal folgende Änderung vornehmen und Bescheid sagen.
https://github.com/MaxWiesel/buildsyste ... ib2.mk#L17

Code: Alles auswählen

	-Doss_fuzz=disabled \
	-Dlibmount=false
Benutzeravatar
annie
NI - Team
Beiträge: 1010
Registriert: Di 5. Apr 2016, 18:46
Wohnort: zuhause
Box: 1x E4HD, 4x HD51,1x VuUno4K

Re: Max Git und HD51 Bau bricht ab

Beitrag von annie »

prepare-for-bs.sh sagt alles aktuell und nix fehlte

die Änderung in der host-libglib2.mk bringt neuen Fehler:
Bildschirmfoto vom 2023-06-18 11-16-53.png
Benutzeravatar
annie
NI - Team
Beiträge: 1010
Registriert: Di 5. Apr 2016, 18:46
Wohnort: zuhause
Box: 1x E4HD, 4x HD51,1x VuUno4K

Re: Max Git und HD51 Bau bricht ab

Beitrag von annie »

Unter Debian11 kommt der Error auch....

Run-time dependency mount found: NO (tried pkgconfig and cmake)

meson.build:1861:2: ERROR: Dependency "mount" not found, tried pkgconfig and cmake
Benutzeravatar
max_10
NI - VIP
Beiträge: 162
Registriert: Di 12. Apr 2016, 13:06

Re: Max Git und HD51 Bau bricht ab

Beitrag von max_10 »

Fragerunde ;-)
Ist das seit dem letzten Update vom BS so und vorher lief es?
oder
Wurde in LinuxMint ein Update auf 21.1 gemacht?
Und eine altes cross mit genommen, um Zeit zu sparen, das geht auf jeden Fall nicht,
weil in LM21.1 gcc12 und neue glibc hinzugekommen ist und man muss cross neu bauen.
oder
Ist es eine frische Version vom BS?
Benutzeravatar
max_10
NI - VIP
Beiträge: 162
Registriert: Di 12. Apr 2016, 13:06

Re: Max Git und HD51 Bau bricht ab

Beitrag von max_10 »

Ok Fehler gefunden, Ubuntu (LinuxMint) verträgt an einer stelle das export nicht, wo Debian es wieder umsetzt,
habe es wieder auf die erste Änderung geändert.
Hat hier in einer frischen VM mit LM21.1 nach der Änderung durch gebaut, vorher hatte ich die selben Fehler wie du. ;-)
Benutzeravatar
annie
NI - Team
Beiträge: 1010
Registriert: Di 5. Apr 2016, 18:46
Wohnort: zuhause
Box: 1x E4HD, 4x HD51,1x VuUno4K

Re: Max Git und HD51 Bau bricht ab

Beitrag von annie »

Vielen Dank

Übrigens hab ich in einer VM ein Debian11, da ist die Path Variable ungünstig gesetzt und kennt kein /usr/sbin,

mkfs.ext4 und parted wird daher für das Flashimage nicht gefunden.

Ich hab für mich die Path Variable in der .bashrc gesetzt/erweitert
Benutzeravatar
max_10
NI - VIP
Beiträge: 162
Registriert: Di 12. Apr 2016, 13:06

Re: Max Git und HD51 Bau bricht ab

Beitrag von max_10 »

Wunsch erhört ;-) habe den PATH im BS erweitert das es ohne Änderung geht.
Benutzeravatar
annie
NI - Team
Beiträge: 1010
Registriert: Di 5. Apr 2016, 18:46
Wohnort: zuhause
Box: 1x E4HD, 4x HD51,1x VuUno4K

Re: Max Git und HD51 Bau bricht ab

Beitrag von annie »

im Moment lässt sich ffmpeg nicht bauen...

.config

Code: Alles auswählen

TARGET_ARCH=arm
BOXTYPE=armbox
BOXMODEL=hd51
FLAVOUR=neutrino-max
GCC_VERSION=13.1.0
OPTIMIZATIONS=size
EXTERNAL_LCD=lcd4linux
IMAGE_LAYOUT=subdirboot
Bildschirmfoto vom 2023-07-04 17-21-07.png
Benutzeravatar
max_10
NI - VIP
Beiträge: 162
Registriert: Di 12. Apr 2016, 13:06

Re: Max Git und HD51 Bau bricht ab

Beitrag von max_10 »

war mein Fehler, sollte jetzt wieder passen.
Benutzeravatar
vanhofen
Administrator
Beiträge: 2908
Registriert: Di 5. Apr 2016, 00:05
Has thanked: 1 time
Been thanked: 3 times

Re: Max Git und HD51 Bau bricht ab

Beitrag von vanhofen »

https://github.com/MaxWiesel/buildsyste ... bcc86c4bd7

Die URL sieht mit ihren zwei Punkten falsch aus.
Benutzeravatar
max_10
NI - VIP
Beiträge: 162
Registriert: Di 12. Apr 2016, 13:06

Re: Max Git und HD51 Bau bricht ab

Beitrag von max_10 »

Ja, Danke „Copy & Paste“ Fehler ;-)
Antworten

Zurück zu „AX/Mutant (HD51), WWIO (BRE2ZE4K), Air Digital (Zgemma H7S/C)“